3rd Party: All Amazon Selling Partner connections are rescheduled due to rate limit changes

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that instance rates are returning to normal levels and affected connectors are syncing successfully.

Incident Summary
Description:
We identified an issue for Amazon Selling Partner connections which resulted in syncs re-scheduling due to the rate limits on the GET_SALES_AND_TRAFFIC_REPORT.

Timeline:
This issue began on 2026-04-24 at 09:00:00 UTC and was resolved on 2026-04-27 at 14:15:00 UTC.

Cause:
We are experiencing the rate limits issue from the third party causing our connectors to reschedule for the GET_SALES_AND_TRAFFIC_REPORT.

Resolution:
A fix has been implemented to skip the tables associated with this report and allowing the connections for a successful sync.
Posted Apr 27, 2026 - 16:00 UTC

Monitoring

We have implemented a mitigation on our end to temporarily skip the SALES_AND_TRAFFIC_BUSINESS_* tables while we await further updates from the third-party. We will continue to monitor the connections.
Posted Apr 27, 2026 - 13:15 UTC

Update

We have observed that all the Amazon Selling Partner connections across Fivetran app, custom app and customer_oauth app are re-scheduling due to the change in rate limits from 3rd party.
Posted Apr 27, 2026 - 08:38 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Apr 27, 2026 - 08:35 UTC
This incident affected: Sales connectors (Amazon Selling Partner).