Multiple connection syncs are failing with an "Internal: Failed to read token" error.

Incident Report for Fivetran

Resolved

This incident has been resolved.

Incident Summary

Issue:
Fivetran: Multiple connection syncs were failing with an Internal: Failed to read token error.

Timeline:
This issue began on May 22, 2026, at 02:47 UTC and was resolved on May 22, 2026, at 02:55 UTC.

Root Cause:
Calls to Firestore (a GCP service) failed due to transient network errors.

Resolution:
The transient issue affecting Firestore services has stabilised, and all affected Fivetran syncs have recovered and are operating normally.
Posted May 22, 2026 - 05:16 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 22, 2026 - 05:05 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted May 22, 2026 - 05:05 UTC
This incident affected: Systems (General Services).