Some Microsoft Ads connectors are failing
Incident Report for Fivetran
Resolved
This incident has been resolved.
Posted Apr 01, 2021 - 12:53 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 01, 2021 - 05:37 UTC
Identified
We've discovered a change in the Bing API which appears to be the root cause of some errors. The source API now requires we refresh the token after HTTP 200 errors. From our investigation, this change appears to have happened around March 25 and is not documented in the changelong for the Bing API.

We are creating new code to account for this requirement so we refresh the token after HTTP 200 errors.
Posted Mar 31, 2021 - 16:52 UTC
Update
We are continuing to investigate some ongoing issues with a number of connectors which the fix has not resolved.
Posted Mar 31, 2021 - 12:36 UTC
Monitoring
The fix was deployed at 3:36pm PDT. We are currently monitoring syncs for the error.
Posted Mar 31, 2021 - 00:17 UTC
Identified
Engineering has developed a fix and we expect it to be released to production by this afternoon pacific time.
Posted Mar 30, 2021 - 17:37 UTC
Update
We are continuing to investigate this issue.
Posted Mar 30, 2021 - 07:00 UTC
Update
We are continuing to investigate this issue.
Posted Mar 30, 2021 - 06:58 UTC
Investigating
We are currently investigating an issue where some Microsoft Ads connectors are failing with a NullPointerException error.
Posted Mar 29, 2021 - 12:57 UTC
This incident affected: Fivetran Services (Replication Servers).