3rd Party: Twitter Ads and Twitter Organic connections are experiencing sync failures due to URI is not absolute error with HTTP 500 Response

Incident Report for Fivetran

Resolved

Incident Summary.

Description: Twitter API started returning Internal Server Error with code 500 when we try to fetch reports.

Timeline: Impact start time around April 10th 21:54:44 UTC to April 11th 12:47:37 UTC

Cause: 3rd party error on twitter side

Resolution: We have implemented a workaround for this by skipping reports for problematic accounts and connectors are back to normal.
Posted Apr 11, 2026 - 14:48 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 11, 2026 - 13:14 UTC

Update

The failure, "URI is not absolute" is a cause of failing Twitter APIs while trying to fetch reports with code 500 and message "internal server error"
Posted Apr 11, 2026 - 13:08 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Apr 11, 2026 - 11:55 UTC
This incident affected: Marketing connectors (Twitter Ads).