3rd Party: Pinterest Ads Connections Failing Due to Upstream API Issues

Incident Report for Fivetran

Resolved

Incident Summary

Description:
We identified an issue where Pinterest Ads connections experienced report failures due to upstream API errors.

Timeline:
The issue began on February 9 at 23:50 UTC and was resolved on February 11 at 00:50 UTC.

Cause:
The failures were caused by errors returned from the upstream Pinterest Ads API during report requests.

Resolution:
A hotfix was deployed to skip the affected endpoints and restore successful syncs. We are continuing to work with Pinterest to address the underlying API issue.
Posted Feb 11, 2026 - 01:33 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 11, 2026 - 01:04 UTC

Update

Pinterest Ads connections are experiencing report failures due to upstream API errors. A hotfix has been deployed to bypass the affected endpoints, and we are working with Pinterest support while continuing to closely monitor connections.
Posted Feb 11, 2026 - 01:04 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Feb 11, 2026 - 01:00 UTC
This incident affected: Marketing connectors (Pinterest Ads).