3rd Party: Few Facebook Ads Connections Failing Due to 500 Internal Server and Socket Connection Errors

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that instance rates are returning to normal levels and affected connectors are syncing successfully.

Incident Summary

Description:
We identified an issue for Facebook Ads connectors which resulted in syncs failing with 500 Internal Server and Socket Connection Errors.

Timeline:
This issue began on 2025-07-28 at 9:52 AM UTC and was resolved at 2025-07-28 at 3:18 PM UTC.

Cause:
The /advideos endpoint from the Facebook API started returning 500 Internal Server errors.

Resolution:
A fix was implemented to handle the 500 errors and the number of retries on socket connection errors was increased.
Posted Jul 28, 2025 - 21:00 UTC

Monitoring

A fix has been implemented, and we are currently monitoring the results.
Posted Jul 28, 2025 - 16:08 UTC

Update

We are currently encountering issues with the /advideos endpoint. The source is returning a 500 Internal Server Error along with socket connection errors when requests are made. Our team has implemented a fix to handle the 500 error and has increased the retry attempts for socket connection errors
Posted Jul 28, 2025 - 15:46 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Jul 28, 2025 - 15:30 UTC
This incident affected: Marketing connectors (Facebook Ads).