Description: We have identified an issue where the SDK connection syncs started failing with the error "Unable to start the Docker daemon process within the timeout"
Timeline: The issue started on December 9, 2025, at 23:00 UTC and was resolved on December 10, 2025, around 02:15 UTC.
Cause: A faulty change intended to use standard Debian jemalloc paths was merged and deployed. This caused the default environment variables to be overridden, which caused Docker startup to fail
Resolution: Hotfix has been deployed to revert the changes, and the connections are syncing successfully after the fix.
Posted Dec 10, 2025 - 03:21 UTC
Monitoring
We identified that the issue was caused by a recent change affecting the Docker daemon process startup. A hotfix has been deployed to revert the changes, and syncs are now succeeding. We will continue to monitor the syncs.
Posted Dec 10, 2025 - 02:25 UTC
Identified
The issue has been identified and we are working to resolve it.
Posted Dec 10, 2025 - 00:30 UTC
This incident affected: Function connectors (Connector SDK).