This incident has been resolved. We have observed that instance rates are returning to normal levels, and affected connectors are syncing successfully.
Incident Summary Description: We identified missing retry logic for REST API-triggered syncs in our internal infrastructure, causing some syncs to silently fail.
Timeline: This issue began on 2025-07-24 at 11:25 UTC and was resolved on 2025-07-25 at 18:15 UTC.
Cause: The issue was due to missing retry logic after migrating API-triggered connectors to the scheduling system.
Resolution: We implemented and deployed a hot-fix to add the necessary missing retry logic for manually triggered syncs.
Posted Jul 25, 2025 - 20:35 UTC
Monitoring
A fix has been implemented, and we are monitoring the results.
Posted Jul 25, 2025 - 18:56 UTC
Update
We've prepared a fix and currently it is under review, we expect that adding the retry logic to the REST API-triggered syncs would help resolve the problem.
Posted Jul 25, 2025 - 11:00 UTC
Identified
We've identified missing retry logic for REST API-triggered syncs in our internal infrastructure, causing some syncs to silently fail. Our team is actively working on a fix.