3rd Party: Amplitude connections are failing with error "java.net.SocketException: Unexpected end of file from server"

Incident Report for Fivetran

Resolved

This incident has been resolved by the Amplitude team. We have observed that instance rates are returning to normal levels, and affected connectors are syncing successfully.

Incident Summary
Description:
There was an incident with Amplitude because of which the Fivetran Amplitude connections started failing with an error "java.net.SocketException: Unexpected end of file from server"

Timeline:
Incident start date: 2025-06-12 01:40 UTC
Incident end date: 2025-06-12 06:03 UTC

Cause:
The issue was caused by an incident on Amplitude's side where there was a delay in their data processing system, causing sync failure. Amplitude status page: https://status.amplitude.com/incidents/cdxknl1pgy2f

Resolution:
The Amplitude team implemented a fix that successfully resolved the issue.
Posted Jun 12, 2025 - 08:59 UTC

Monitoring

The issue has been identified by Amplitude, and they confirmed that there was a delay in their data processing system. The issue has now been resolved on their end, and we are actively monitoring the connection performance.

The live status is made available on the Amplitude status page here: https://status.amplitude.com/incidents/cdxknl1pgy2f
Posted Jun 12, 2025 - 05:43 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Jun 12, 2025 - 01:50 UTC
This incident affected: Event connectors (Amplitude).