Pardot Connectors Failing with Error "while syncing object type com.fivetran.integrations.pardot.model.ExternalActivity"
Incident Report for Fivetran
Resolved
This incident has been resolved. We have observed that instance rates have returned to normal levels and affected Connections are syncing successfully.

Incident Summary
Description:
We identified an issue for the Pardot Connector, which resulted in syncs failing with an error containing "while syncing object type com.fivetran.integrations.pardot.model.ExternalActivity".

Timeline:
This issue began on December 20th at 07:11 UTC and was resolved on December 20th at 14:19 UTC.

Cause:
An unexpected error code started to be returned from the Pardot API with queries to the `/external-activities` endpoint. Requests to this endpoint started to fail with a "404 Not Found" error and response code of "198". This error and response code was identified to be undocumented in Pardot documentation.

Resolution:
We raised a fix to handle this new error code, ensuring Pardot connections hitting this error proceeded successfully.
Posted Dec 20, 2024 - 14:47 UTC
Monitoring
Pardot Connectors are failing with an Error containing `while syncing object type com.fivetran.integrations.pardot.model.ExternalActivity`.

We have confirmed this is due to an unexpected error code returned when the Pardot API with queries to the `/external-activities` endpoint. In some cases we have identified that calls to this endpoint now fail with a "404 Not Found" error and response code of "198".

We have deployed a fix to handle for this error and response code. We are continuing to monitor to ensure the success of the fix.
Posted Dec 20, 2024 - 12:57 UTC
Identified
The issue has been identified and we are working to resolve it.
Posted Dec 20, 2024 - 12:55 UTC
This incident affected: Marketing connectors (Pardot).