Typeform Connectors Experiencing Sync Failures

Incident Report for Fivetran

Resolved

This incident has been resolved.

Incident Summary
Description:
We encountered an issue affecting Typeform connectors, where sync failures were observed.

Timeline:
This issue began on July 9th, 2025 at 17:30 UTC and was resolved on July 10th, 2025 at 05:00 UTC.

Root Cause:
The issue was caused by a bug introduced in a recent code change.

Resolution:
We resolved the issue by rolling back the change, which restored normal functionality.
Posted Jul 10, 2025 - 06:17 UTC

Monitoring

We have applied a fix to address the issue that was causing sync failures. We will continue to monitor all affected connectors to ensure they return to normal sync functionality.
Posted Jul 09, 2025 - 23:16 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Jul 09, 2025 - 23:05 UTC
This incident affected: Support connectors (Typeform).