Multiple Connector SDK connections failing with Authentication error

Incident Report for Fivetran

Resolved

We have confirmed that fix resolved the issues and the connections are syncing as expected.

Incident Summary
Description:
We observed multiple Connector SDK connections failing with the error below:
Error getting access token for service account: 400 Bad Request.

Timeline:
Start: 11:20 UTC
Resolution: 13:20 UTC

Cause:
An internal automation issue mistakenly affected a production environment, causing a service interruption.

Resolution:
The interruption has been resolved, and we have implemented new safeguards to prevent a recurrence.
Posted Aug 20, 2025 - 15:10 UTC

Monitoring

A fix has been implemented and we are observing successful connections. We are continuing to monitor for any further issues.
Posted Aug 20, 2025 - 13:28 UTC

Update

We are seeing multiple Connector SDK connections failing with the error below:
Error getting access token for service account: 400 Bad Request

The connections display broken state on the Fivetran dashboard. Fivetran engineering team is working on the fix. We will provide updates as we learn more.
Posted Aug 20, 2025 - 13:21 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Aug 20, 2025 - 12:55 UTC
This incident affected: Function connectors (Connector SDK).