3rd Party: Ramp connections are failing with "403 Forbidden" error

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that instance rates are returning to normal levels and affected connectors are syncing successfully.

Incident Summary
Description:
We identified an issue with Ramp connections, which resulted in sync failures with a 403 Forbidden error.

Timeline:
This issue began on Jan 7, 2026, at 22:30 UTC and was resolved on Jan 8, 2026, at 08:40 UTC.

Cause:
Multiple endpoints (including Bill, Purchase Order, Business Entity, Vendor, Merchant, spend_program, and limits) require specific permissions to sync. A recent third-party change caused missing-permission errors to return a 403 Forbidden instead of a 400 Bad Request for these endpoints. This change bypassed the existing logic, resulting in connection sync failures.

Resolution:
We have implemented a fix to address the 403 Forbidden errors.
Posted Jan 08, 2026 - 10:45 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 08, 2026 - 10:20 UTC

Identified

We are now observing 403 Forbidden errors on the spend_program and limits endpoints, in addition to the previously impacted endpoints. The issue is consistent with a scope-related insufficient permissions error.

We are working on a hotfix to extend the fix to include these endpoints, handle the 403 Forbidden error, and fix the issue.
Posted Jan 08, 2026 - 08:40 UTC

Monitoring

The hotfix has been deployed successfully. We are monitoring the connector syncs now.
Posted Jan 08, 2026 - 06:13 UTC

Update

A hotfix has been created and is currently being deployed
Posted Jan 08, 2026 - 05:36 UTC

Update

Multiple endpoints (including Bill, Purchase Order, Business Entity, Vendor, and Merchant) require specific permissions to sync. A recent third-party change caused missing-permission errors to return a 403 Forbidden instead of a 400 Bad Request. This change bypassed the existing skip logic, resulting in connection sync failures.

We are working on a hotfix to handle the 403 Forbidden error to fix the issue.
Posted Jan 08, 2026 - 03:20 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Jan 08, 2026 - 03:05 UTC
This incident affected: Finance connectors (Ramp).