The affected connections have resumed syncing successfully.
Incident Summary
Description: An issue was identified with multiple types of connectors, where syncs would reschedule or fail with an "io.grpc.StatusRuntimeException: DEADLINE_EXCEEDED: ClientCall started after CallOptions deadline was exceeded" error.
Timeline: The incident began on 2025-10-03 at 16:00 UTC and was resolved on 2025-10-04 at 00:45 UTC.
Cause: Sync errors occurred when connections reached a timeout with Fivetran servers.
Resolution: A fix was deployed to remove the timeout and restore expected behavior. Affected connections should succeed on the next attempt, requiring no manual intervention.
Posted Oct 04, 2025 - 00:45 UTC
Update
We are continuing to monitor for any further issues.
Posted Oct 03, 2025 - 21:55 UTC
Monitoring
We have deployed a fix for this issue by removing the 30 minute timeout.
We will continue to monitor all affected connectors until they resume their normal sync functionality.
Posted Oct 03, 2025 - 20:44 UTC
Update
The requests to Fivetran server started failing with a timeout.
As the result, the connectors were failing or rescheduling even after successful extraction/processing/loading.
Posted Oct 03, 2025 - 19:30 UTC
Identified
Beginning at 16:00 UTC, some connection syncs started rescheduling or failing with the following error:
"io.grpc.StatusRuntimeException: DEADLINE_EXCEEDED: ClientCall started after CallOptions deadline was exceeded"
Posted Oct 03, 2025 - 16:00 UTC
This incident affected: Systems (General Services).